Шаблоны Option 82

Режим IP Unnumbered | Шаблоны Option 82 | DHCP сервер

L для пропуска
M модуль
V влан
P порт
CP порт начинается с 0. система делает +1 к порту подходит для Cisco

Если в шаблоне используется VLAN+PORT то абонента находит по VLAN+PORT Если в шаблоне указан VLAN+MODULE+PORT то абонента находит по VLAN+MODULE+PORT

Формируем шаблон circuit-id под свое оборудование.

Если opt.82 настроили верно, в логах DHCP видим circuit-id. Нам необходимо извлечь два параметра - vlanid и port

В примере рассмотрим circuit-id вида 0x053e000a01, это составное шестнадцатиричное значение. Также, нам известно, что эта опция приходит с 1-го порта в 1342-м влане. Переведем из dec в hex: 1342 влан = 053E, 1 порт = 01

0x 053e 000a 01

составляем шабон:

L=2,V=4,L=4,P=2

где L - неиспользуемые значения, V - влан, P - порт.

шаблон

L=4,V=4,CP=4

шаблон

 L=6,V=4,L=6,P=2 

шаблон

L=6,V=4,P=4

шаблон

L=2,P=2,V=4
проверенно на NextHop 2530-24T; NextHop 2540-24T

шаблон

L=2,V=4,L=2,P=2

Проверенно с таким конфигом:

!
aaa authentication login default line
aaa authentication enable default line
!
interface FastEthernet0/1
 filter arp
 filter icmp
 switchport pvid 437
 spanning-tree guard loop
  dhcp snooping information circuit-id hex 01-b5-00-01
  dhcp snooping information remote-id hex 00-e0-0f-1a-3b-b3
 keepalive
 storm-control broadcast threshold 128
 storm-control multicast threshold 128
!
interface FastEthernet0/2
 filter arp
 filter icmp
 switchport pvid 437
 spanning-tree guard loop
  dhcp snooping information circuit-id hex 01-b5-00-02
  dhcp snooping information remote-id hex 00-e0-0f-1a-3b-b3
 keepalive
 storm-control broadcast threshold 128
 storm-control multicast threshold 128
!
interface FastEthernet0/3
 filter arp
 filter icmp
 switchport pvid 437
 spanning-tree guard loop
  dhcp snooping information circuit-id hex 01-b5-00-03
  dhcp snooping information remote-id hex 00-e0-0f-1a-3b-b3
 keepalive
 storm-control broadcast threshold 128
 storm-control multicast threshold 128
!
interface FastEthernet0/4
 filter arp
 filter icmp
 switchport pvid 437
 spanning-tree guard loop
  dhcp snooping information circuit-id hex 01-b5-00-04
  dhcp snooping information remote-id hex 00-e0-0f-1a-3b-b3
 keepalive
 storm-control broadcast threshold 128
 storm-control multicast threshold 128
!
interface FastEthernet0/5
 filter arp
 filter icmp
 switchport pvid 437
 spanning-tree guard loop
  dhcp snooping information circuit-id hex 01-b5-00-05
  dhcp snooping information remote-id hex 00-e0-0f-1a-3b-b3
 keepalive
 storm-control broadcast threshold 128
 storm-control multicast threshold 128
!
interface FastEthernet0/6
 filter arp
 filter icmp
 switchport pvid 437
 spanning-tree guard loop
  dhcp snooping information circuit-id hex 01-b5-00-06
  dhcp snooping information remote-id hex 00-e0-0f-1a-3b-b3
 keepalive
 storm-control broadcast threshold 128
 storm-control multicast threshold 128
!
interface FastEthernet0/7
 filter arp
 filter icmp
 switchport pvid 437
 spanning-tree guard loop
  dhcp snooping information circuit-id hex 01-b5-00-07
  dhcp snooping information remote-id hex 00-e0-0f-1a-3b-b3
 keepalive
 storm-control broadcast threshold 128
 storm-control multicast threshold 128
!
interface FastEthernet0/8
 filter arp
 filter icmp
 switchport pvid 437
 spanning-tree guard loop
  dhcp snooping information circuit-id hex 01-b5-00-08
  dhcp snooping information remote-id hex 00-e0-0f-1a-3b-b3
 keepalive
 storm-control broadcast threshold 128
 storm-control multicast threshold 128
!
interface FastEthernet0/9
 filter arp
 filter icmp
 switchport pvid 437
 spanning-tree guard loop
  dhcp snooping information circuit-id hex 01-b5-00-09
  dhcp snooping information remote-id hex 00-e0-0f-1a-3b-b3
 keepalive
 storm-control broadcast threshold 128
 storm-control multicast threshold 128
!
interface FastEthernet0/10
 filter arp
 filter icmp
 switchport pvid 437
 spanning-tree guard loop
  dhcp snooping information circuit-id hex 01-b5-00-0a
  dhcp snooping information remote-id hex 00-e0-0f-1a-3b-b3
 keepalive
 storm-control broadcast threshold 128
 storm-control multicast threshold 128
!
interface FastEthernet0/11
 filter arp
 filter icmp
 switchport pvid 437
 spanning-tree guard loop
  dhcp snooping information circuit-id hex 01-b5-00-0b
  dhcp snooping information remote-id hex 00-e0-0f-1a-3b-b3
 keepalive
 storm-control broadcast threshold 128
 storm-control multicast threshold 128
!
interface FastEthernet0/12
 filter arp
 filter icmp
 switchport pvid 437
 spanning-tree guard loop
  dhcp snooping information circuit-id hex 01-b5-00-0c
  dhcp snooping information remote-id hex 00-e0-0f-1a-3b-b3
 keepalive
 storm-control broadcast threshold 128
 storm-control multicast threshold 128
!
interface FastEthernet0/13
 filter arp
 filter icmp
 switchport pvid 437
 spanning-tree guard loop
  dhcp snooping information circuit-id hex 01-b5-00-0d
  dhcp snooping information remote-id hex 00-e0-0f-1a-3b-b3
 keepalive
 storm-control broadcast threshold 128
 storm-control multicast threshold 128
!
interface FastEthernet0/14
 filter arp
 filter icmp
 switchport pvid 437
 spanning-tree guard loop
  dhcp snooping information circuit-id hex 01-b5-00-0e
  dhcp snooping information remote-id hex 00-e0-0f-1a-3b-b3
 keepalive
 storm-control broadcast threshold 128
 storm-control multicast threshold 128
!
interface FastEthernet0/15
 filter arp
 filter icmp
 switchport pvid 437
 spanning-tree guard loop
  dhcp snooping information circuit-id hex 01-b5-00-0f
  dhcp snooping information remote-id hex 00-e0-0f-1a-3b-b3
 keepalive
 storm-control broadcast threshold 128
 storm-control multicast threshold 128
!
interface FastEthernet0/16
 filter arp
 filter icmp
 switchport pvid 437
 spanning-tree guard loop
  dhcp snooping information circuit-id hex 01-b5-00-10
  dhcp snooping information remote-id hex 00-e0-0f-1a-3b-b3
 keepalive
 storm-control broadcast threshold 128
 storm-control multicast threshold 128
!
interface FastEthernet0/17
 filter arp
 filter icmp
 switchport pvid 437
 spanning-tree guard loop
  dhcp snooping information circuit-id hex 01-b5-00-11
  dhcp snooping information remote-id hex 00-e0-0f-1a-3b-b3
 keepalive
 storm-control broadcast threshold 128
 storm-control multicast threshold 128
!
interface FastEthernet0/18
 filter arp
 filter icmp
 switchport pvid 437
 spanning-tree guard loop
  dhcp snooping information circuit-id hex 01-b5-00-12
  dhcp snooping information remote-id hex 00-e0-0f-1a-3b-b3
 keepalive
 storm-control broadcast threshold 128
 storm-control multicast threshold 128
!
interface FastEthernet0/19
 filter arp
 filter icmp
 switchport pvid 437
 spanning-tree guard loop
  dhcp snooping information circuit-id hex 01-b5-00-13
  dhcp snooping information remote-id hex 00-e0-0f-1a-3b-b3
 keepalive
 storm-control broadcast threshold 128
 storm-control multicast threshold 128
!
interface FastEthernet0/20
 filter arp
 filter icmp
 switchport pvid 437
 spanning-tree guard loop
  dhcp snooping information circuit-id hex 01-b5-00-14
  dhcp snooping information remote-id hex 00-e0-0f-1a-3b-b3
 keepalive
 storm-control broadcast threshold 128
 storm-control multicast threshold 128
!
interface FastEthernet0/21
 filter arp
 filter icmp
 switchport pvid 437
 spanning-tree guard loop
  dhcp snooping information circuit-id hex 01-b5-00-15
  dhcp snooping information remote-id hex 00-e0-0f-1a-3b-b3
 keepalive
 storm-control broadcast threshold 128
 storm-control multicast threshold 128
!
interface FastEthernet0/22
 filter arp
 filter icmp
 switchport pvid 437
 spanning-tree guard loop
  dhcp snooping information circuit-id hex 01-b5-00-16
  dhcp snooping information remote-id hex 00-e0-0f-1a-3b-b3
 keepalive
 storm-control broadcast threshold 128
 storm-control multicast threshold 128
!
interface FastEthernet0/23
 filter arp
 filter icmp
 switchport pvid 437
 spanning-tree guard loop
  dhcp snooping information circuit-id hex 01-b5-00-17
  dhcp snooping information remote-id hex 00-e0-0f-1a-3b-b3
 keepalive
 storm-control broadcast threshold 128
 storm-control multicast threshold 128
!
interface FastEthernet0/24
 filter arp
 filter icmp
 switchport pvid 437
 spanning-tree guard loop
  dhcp snooping information circuit-id hex 01-b5-00-18
  dhcp snooping information remote-id hex 00-e0-0f-1a-3b-b3
 keepalive
 storm-control broadcast threshold 128
 storm-control multicast threshold 128
!
interface GigaEthernet0/1
 switchport trunk vlan-allowed 100,437
  dhcp snooping trust
!
interface GigaEthernet0/2
 switchport trunk vlan-allowed 100,437
 switchport mode trunk
  dhcp snooping trust
!
interface GigaEthernet0/3
 switchport trunk vlan-allowed 100,437
 switchport mode trunk
  dhcp snooping trust
!
interface GigaEthernet0/4
 switchport trunk vlan-allowed 100,437
 switchport mode trunk
  dhcp snooping trust
!
interface VLAN100
 ip address 10.7.8.249 255.255.248.0
!
!
filter threshold arp 200
filter enable
!
vlan 100
 name managed
!
vlan 1,100,437
!
!
!
!
ip dhcp-relay snooping
ip dhcp-relay snooping vlan  437
ip verify source vlan  437
ip dhcp-relay snooping information option format manual
!
  • billing/configuration/dhcp_template.txt
  • Последние изменения: 23 месяц (-ев) назад
  • — Александр Дудяк