Роскомнадзор. Блокировка средствами Mikrotik RouterOS

Доступно с версии 2.8.14

Продолжение темы - Роскомнадзор блокировка по IP адресу, теперь рассмотрим как это сделать средствами Mikrotik RouterOS. Как настроить получение выгрузки от РосКомНадзора - ознакомится можно тут.

1. Скачайте свежий дистрибутив, в папке /DISTR/RKN - rkn-mikrotik.php скопируйте его в /var/www/mikbill/admin/app/etc/roskomnadzor

2. Проверьте работу авторизацию по ключу между серверами - ознакомится можно тут.

3. Проверьте в справочнике "Сервера NAS" следующие настройки:

direct|
  • Логин и пароль пользователя имеющего права суперпользователя.
не забудьте также включить на устройстве службу ftp
  • Включить "использование SSH" для управления сервером доступа.
  • Тип NAS - должен иметь значение - Mikrotik или Hotspot

4. Проверка работы скрипта:

  • Перейдите в каталог где находится скрипт и выгрузка с РосКомНадзора. И запустите скрипт rkn-mikrotik.php через интерпретатор php.
cd /var/www/mikbill/admin/app/etc/roskomnadzor

php rkn-mikrotik.php
  • У Вас должен в текущем каталоге появится файл rkn_iplist.rsc, который должен был скопирован и выполнен на серверах Mikrotik.
cat rkn_iplist.rcs

/ip firewall address-list remove [/ip firewall address-list find list=RKN_BLK_LIST]
/ip firewall address-list add list="RKN_BLK_LIST" address=109.69.58.58
/ip firewall address-list add list="RKN_BLK_LIST" address=94.76.213.163

..................
  • На сервере доступа проверьте наличие списка с адресами. По умолчанию список имеет имя - RKN_BLK_LIST, изменить можно во 2-ей строке, переменная - name_list.
 |

7. Теперь можете добавить для этого списка запрещающее правило в firewall:

/ip firewall filter add action=reject chain=forward dst-address-list=RKN_BLK_LIST reject-with=icmp-admin-prohibited
  • billing/howto/rkn_mikrotik.txt
  • Последние изменения: 3 лет назад
  • — Александр Дудяк